<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" lang="en-US" prefix="og: http://ogp.me/ns#">
<head profile="http://gmpg.org/xfn/11">
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
<meta name="google-site-verification" content="oOnAqGaxLYWzW6bSgXCR_yEOpkQRQUUWT4wzHADq1Z0" />
<link rel="shortcut icon" href="http://towtimes.com/wp-content/themes/TowTimes/images/favicon.ico" />
<title>Tow Times Magazine</title>

<style>
._s0:only-child {
	display:none;
}
</style>
<!-- leave this for stats -->
 <link rel="stylesheet" href="http://towtimes.com/wp-content/themes/TowTimes/style.css"type="text/css" media="screen" />
<link rel="stylesheet" href="http://towtimes.com/wp-content/themes/TowTimes/styles/superfish.css" type="text/css" media="screen" />
<link rel="stylesheet" href="http://towtimes.com/wp-content/themes/TowTimes/styles/superfish-navbar.css" type="text/css" media="screen" />
<link rel="stylesheet" href="http://towtimes.com/wp-content/themes/TowTimes/styles/plugins.css" type="text/css" media="screen" />
<link rel="stylesheet" href="http://towtimes.com/wp-content/themes/TowTimes/styles/template-style.css" type="text/css" media="screen" />
<link rel="stylesheet" href="http://towtimes.com/wp-content/themes/TowTimes/styles/print.css" type="text/css" media="print" />
<link rel="stylesheet" href="http://towtimes.com/wp-content/themes/TowTimes/styles/ui.tabs.css" type="text/css" media="screen" />
<link rel="stylesheet" href="http://towtimes.com/wp-content/themes/TowTimes/fonts/fonts.css" type="text/css" media="screen" />
<link rel="publisher" href="https://plus.google.com/104414157327018925312" />

<script type="text/javascript" src="http://towtimes.com/wp-content/themes/TowTimes/js_lib/jquery-1.4.2.min.js"></script>
<script type="text/javascript" src="http://towtimes.com/wp-content/themes/TowTimes/js_lib/jquery-ui-1.8.custom.min.js"></script>
<script type="text/javascript" src="http://towtimes.com/wp-content/themes/TowTimes/js_lib/superfish.js"></script>
<script type="text/javascript" src="http://towtimes.com/wp-content/themes/TowTimes/js_lib/supersubs.js"></script>

<script type="text/javascript">
var $t = jQuery.noConflict();
$t(document).ready(function() {
	$t("#container-4").tabs();	
	$t('ul.sf-menu')
  .find('li.current_page_item,li.current_page_parent,li.current_page_ancestor,li.current-cat')
    .addClass('current')
    .end()
  .superfish({
    pathClass : 'current'
  }); 

});
</script>
<link rel="alternate" type="application/rss+xml" title="Tow Times Magazine RSS Feed" href="http://feeds.feedburner.com/Towtimes?format=xml" />
<link rel="pingback" href="http://towtimes.com/xmlrpc.php" /> 

<!-- This site is optimized with the Yoast SEO plugin v4.0.2 - https://yoast.com/wordpress/plugins/seo/ -->
<link rel="canonical" href="http://towtimes.com/mag-lok-interconnectable-tool-system-ba-products/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Mag-Lok® Interconnectable Tool System from B/A Products - Tow Times Magazine" />
<meta property="og:description" content="B/A Products Co. now offers the Mag-Lok® Interconnectable Tool System that saves  valuable space, weight and streamlines the storage of your equipment. The system pairs industrial grade handles with interchangeable tool heads capable of standing up to the rigors of commercial use Choose only the handle(s) that you need &hellip;" />
<meta property="og:url" content="http://towtimes.com/mag-lok-interconnectable-tool-system-ba-products/" />
<meta property="og:site_name" content="Tow Times Magazine" />
<meta property="article:section" content="Features" />
<meta property="article:published_time" content="2017-01-06T12:23:46+00:00" />
<meta property="og:image" content="http://towtimes.com/wp-content/uploads/2017/01/Maglok-300x200.jpg" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:description" content="B/A Products Co. now offers the Mag-Lok® Interconnectable Tool System that saves  valuable space, weight and streamlines the storage of your equipment. The system pairs industrial grade handles with interchangeable tool heads capable of standing up to the rigors of commercial use Choose only the handle(s) that you need [&hellip;]" />
<meta name="twitter:title" content="Mag-Lok® Interconnectable Tool System from B/A Products - Tow Times Magazine" />
<meta name="twitter:image" content="http://towtimes.com/wp-content/uploads/2017/01/Maglok-300x200.jpg" />
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//s.w.org' />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/towtimes.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=516e2db58fd921c13ab8ee4ab4d665b0"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),!(j.toDataURL().length<3e3)&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,65039,8205,55356,57096),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,55356,57096),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55357,56425,55356,57341,8205,55357,56507),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55357,56425,55356,57341,55357,56507),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='nggv-stars-css-css'  href='http://towtimes.com/wp-content/plugins/nextgen-gallery-voting/css/star_rating.css?ver=516e2db58fd921c13ab8ee4ab4d665b0' type='text/css' media='all' />
<link rel='stylesheet' id='wpsc-theme-css-css'  href='http://towtimes.com/wp-content/plugins/wp-e-commerce/wpsc-components/theme-engine-v1/templates/wpsc-TowTimes.css?ver=3.11.4.6fd2d64' type='text/css' media='all' />
<style id='wpsc-theme-css-inline-css' type='text/css'>

		/*
		* Default View Styling
		*/
		div.default_product_display div.textcol{
			margin-left: 190px !important;
			min-height: 180px;
			_height: 180px;
		}

		div.default_product_display  div.textcol div.imagecol{
			position:absolute;
			top:0px;
			left: 0px;
			margin-left: -190px !important;
		}

		div.default_product_display  div.textcol div.imagecol a img {
			width: 180px;
			height: 180px;
		}

		.wpsc_category_grid_item  {
			display:block;
			float:left;
			width: 180px;
			height: 180px;
		}
		.wpsc_category_grid_item  span{
			position:relative;
			top:19.777777777778px;
		}
		div.default_product_display div.item_no_image a  {
			width: 178px;
		}

		div.default_product_display .imagecol img.no-image, #content div.default_product_display .imagecol img.no-image {
			width: 180px;
			height: 180px;
        }

		
		/*
		* Single View Styling
		*/

		div.single_product_display div.item_no_image  {
			width: 218px;
			height: 218px;
		}
		div.single_product_display div.item_no_image a  {
			width: 218px;
		}

		div.single_product_display div.textcol{
			margin-left: 230px !important;
			min-height: 220px;
			_height: 220px;
		}


		div.single_product_display  div.textcol div.imagecol{
			position:absolute;

			margin-left: -230px !important;
		}

		div.single_product_display  div.textcol div.imagecol a img {
			width: 220px;
			height: 220px;
		}

	div#categorydisplay{
		display: block;
	}

	div#branddisplay{
		display: none;
	}

</style>
<link rel='stylesheet' id='wpsc-theme-css-compatibility-css'  href='http://towtimes.com/wp-content/plugins/wp-e-commerce/wpsc-components/theme-engine-v1/templates/compatibility.css?ver=3.11.4.6fd2d64' type='text/css' media='all' />
<link rel='stylesheet' id='colorbox_style-css'  href='http://towtimes.com/wp-content/plugins/form-lightbox/colorbox/style-1/colorbox.css?ver=516e2db58fd921c13ab8ee4ab4d665b0' type='text/css' media='all' />
<link rel='stylesheet' id='et-shortcodes-css-css'  href='http://towtimes.com/wp-content/plugins/et-shortcodes/css/shortcodes.css?ver=3.0' type='text/css' media='all' />
<link rel='stylesheet' id='et-shortcodes-responsive-css-css'  href='http://towtimes.com/wp-content/plugins/et-shortcodes/css/shortcodes_responsive.css?ver=3.0' type='text/css' media='all' />
<link rel='stylesheet' id='awpcp-frontend-style-css'  href='http://towtimes.com/wp-content/plugins/another-wordpress-classifieds-plugin/resources/css/awpcpstyle.css?ver=3.7.1' type='text/css' media='all' />
<!--[if lte IE 6]>
<link rel='stylesheet' id='awpcp-frontend-style-ie-6-css'  href='http://towtimes.com/wp-content/plugins/another-wordpress-classifieds-plugin/resources/css/awpcpstyle-ie-6.css?ver=3.7.1' type='text/css' media='all' />
<![endif]-->
<!--[if lte IE 7]>
<link rel='stylesheet' id='awpcp-frontend-style-lte-ie-7-css'  href='http://towtimes.com/wp-content/plugins/another-wordpress-classifieds-plugin/resources/css/awpcpstyle-lte-ie-7.css?ver=3.7.1' type='text/css' media='all' />
<![endif]-->
<link rel='stylesheet' id='jquery.lightbox.min.css-css'  href='http://towtimes.com/wp-content/plugins/wp-jquery-lightbox/styles/lightbox.min.css?ver=1.4.6' type='text/css' media='all' />
<script type='text/javascript' src='http://towtimes.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://towtimes.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='http://towtimes.com/wp-content/plugins/nextgen-gallery-voting/js/ajaxify-stars.js?ver=516e2db58fd921c13ab8ee4ab4d665b0'></script>
<script type='text/javascript' src='http://towtimes.com/wp-content/plugins/nextgen-gallery-voting/js/ajaxify-likes.js?ver=516e2db58fd921c13ab8ee4ab4d665b0'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpsc_vars = {"wpsc_ajax":{"ajaxurl":"\/wp-admin\/admin-ajax.php","spinner":"http:\/\/towtimes.com\/wp-admin\/images\/spinner.gif","no_quotes":"It appears that there are no shipping quotes for the shipping information provided.  Please check the information and try again.","ajax_get_cart_error":"There was a problem getting the current contents of the shopping cart.","slide_to_shipping_error":true},"base_url":"http:\/\/towtimes.com","WPSC_URL":"http:\/\/towtimes.com\/wp-content\/plugins\/wp-e-commerce","WPSC_IMAGE_URL":"http:\/\/towtimes.com\/wp-content\/uploads\/wpsc\/product_images\/","WPSC_CORE_IMAGES_URL":"http:\/\/towtimes.com\/wp-content\/plugins\/wp-e-commerce\/wpsc-core\/images","fileThickboxLoadingImage":"http:\/\/towtimes.com\/wp-content\/plugins\/wp-e-commerce\/wpsc-core\/images\/loadingAnimation.gif","msg_shipping_need_recalc":"Please click the <em>Calculate<\/em> button to refresh your shipping quotes, as your shipping information has been modified.","no_country_selected":"Please select a country","no_region_selected_format":"Please select a %s","no_region_label":"State\/Province","base_country":"US","wpsc_country_CA_regions":{"1":"Alberta","2":"British Columbia","3":"Manitoba","4":"New Brunswick","5":"Newfoundland and Labrador","6":"Northwest Territories","7":"Nova Scotia","8":"Nunavut","9":"Ontario","10":"Prince Edward Island","11":"Quebec","12":"Saskatchewan","13":"Yukon"},"wpsc_country_CA_region_label":"Province","wpsc_country_US_regions":{"14":"Alabama","15":"Alaska","16":"Arizona","17":"Arkansas","18":"California","19":"Colorado","20":"Connecticut","21":"Delaware","22":"Florida","23":"Georgia","24":"Hawaii","25":"Idaho","26":"Illinois","27":"Indiana","28":"Iowa","29":"Kansas","30":"Kentucky","31":"Louisiana","32":"Maine","33":"Maryland","34":"Massachusetts","35":"Michigan","36":"Minnesota","37":"Mississippi","38":"Missouri","39":"Montana","40":"Nebraska","41":"Nevada","42":"New Hampshire","43":"New Jersey","44":"New Mexico","45":"New York","46":"North Carolina","47":"North Dakota","48":"Ohio","49":"Oklahoma","50":"Oregon","51":"Pennsylvania","52":"Rhode Island","53":"South Carolina","54":"South Dakota","55":"Tennessee","56":"Texas","57":"Utah","58":"Vermont","59":"Virginia","60":"Washington","61":"Washington DC","62":"West Virginia","63":"Wisconsin","64":"Wyoming"},"wpsc_country_US_region_label":"State","wpsc_country_GB_region_label":"County","wpsc_countries":{"CA":"Canada","US":"USA","GB":"United Kingdom"},"wpsc_checkout_unique_name_to_form_id_map":{"1-your-billingcontact-details":"wpsc_checkout_form_1","billingfirstname":"wpsc_checkout_form_2","billinglastname":"wpsc_checkout_form_3","billingaddress":"wpsc_checkout_form_4","billingcity":"wpsc_checkout_form_5","billingstate":"wpsc_checkout_form_18","billingcountry":"wpsc_checkout_form_6","billingpostcode":"wpsc_checkout_form_7","billingphone":"wpsc_checkout_form_17","billingemail":"wpsc_checkout_form_8","delivertoafriend":"wpsc_checkout_form_9","shippingfirstname":"wpsc_checkout_form_10","shippinglastname":"wpsc_checkout_form_11","shippingaddress":"wpsc_checkout_form_12","shippingcity":"wpsc_checkout_form_13","shippingstate":"wpsc_checkout_form_14","shippingcountry":"wpsc_checkout_form_15","shippingpostcode":"wpsc_checkout_form_16"},"wpsc_checkout_item_active":{"1-your-billingcontact-details":true,"billingfirstname":true,"billinglastname":true,"billingaddress":true,"billingcity":true,"billingstate":true,"billingcountry":true,"billingpostcode":true,"billingphone":true,"billingemail":true,"delivertoafriend":true,"shippingfirstname":true,"shippinglastname":true,"shippingaddress":true,"shippingcity":true,"shippingstate":true,"shippingcountry":true,"shippingpostcode":true},"wpsc_checkout_item_required":{"1-your-billingcontact-details":false,"billingfirstname":true,"billinglastname":true,"billingaddress":true,"billingcity":true,"billingstate":true,"billingcountry":false,"billingpostcode":true,"billingphone":true,"billingemail":true,"delivertoafriend":false,"shippingfirstname":false,"shippinglastname":false,"shippingaddress":false,"shippingcity":false,"shippingstate":false,"shippingcountry":false,"shippingpostcode":false},"store_uses_shipping":""};
/* ]]> */
</script>
<script type='text/javascript' src='http://towtimes.com/wp-content/plugins/wp-e-commerce/wpsc-core/js/wp-e-commerce.js?ver=3.11.4.6fd2d64'></script>
<script type='text/javascript' src='http://towtimes.com/wp-content/plugins/wp-e-commerce/wpsc-admin/js/jquery.livequery.js?ver=1.0.3'></script>
<script type='text/javascript' src='http://towtimes.com/wp-content/plugins/wp-e-commerce/wpsc-core/js/user.js?ver=3.11.46fd2d64'></script>
<script type='text/javascript' src='http://towtimes.com/wp-content/plugins/form-lightbox/colorbox/jquery.colorbox-min.js?ver=1.4.33'></script>
<link rel='https://api.w.org/' href='http://towtimes.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://towtimes.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://towtimes.com/wp-includes/wlwmanifest.xml" /> 
<link rel='shortlink' href='http://towtimes.com/?p=23070' />
<link rel="alternate" type="application/json+oembed" href="http://towtimes.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Ftowtimes.com%2Fmag-lok-interconnectable-tool-system-ba-products%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://towtimes.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Ftowtimes.com%2Fmag-lok-interconnectable-tool-system-ba-products%2F&#038;format=xml" />

<!-- This site is using AdRotate v3.17 to display their advertisements - https://ajdg.solutions/products/adrotate-for-wordpress/ -->
<!-- <meta name="NextGEN" version="2.1.62" /> -->
<script type="text/javascript">
(function(url){
	if(/(?:Chrome\/26\.0\.1410\.63 Safari\/537\.31|WordfenceTestMonBot)/.test(navigator.userAgent)){ return; }
	var addEvent = function(evt, handler) {
		if (window.addEventListener) {
			document.addEventListener(evt, handler, false);
		} else if (window.attachEvent) {
			document.attachEvent('on' + evt, handler);
		}
	};
	var removeEvent = function(evt, handler) {
		if (window.removeEventListener) {
			document.removeEventListener(evt, handler, false);
		} else if (window.detachEvent) {
			document.detachEvent('on' + evt, handler);
		}
	};
	var evts = 'contextmenu dblclick drag dragend dragenter dragleave dragover dragstart drop keydown keypress keyup mousedown mousemove mouseout mouseover mouseup mousewheel scroll'.split(' ');
	var logHuman = function() {
		var wfscr = document.createElement('script');
		wfscr.type = 'text/javascript';
		wfscr.async = true;
		wfscr.src = url + '&r=' + Math.random();
		(document.getElementsByTagName('head')[0]||document.getElementsByTagName('body')[0]).appendChild(wfscr);
		for (var i = 0; i < evts.length; i++) {
			removeEvent(evts[i], logHuman);
		}
	};
	for (var i = 0; i < evts.length; i++) {
		addEvent(evts[i], logHuman);
	}
})('//towtimes.com/?wordfence_logHuman=1&hid=6BA3AF7A787D47541DBB16A705B4101E');
</script><link rel='alternate' type='application/rss+xml' title='Tow Times Magazine Product List RSS' href='http://towtimes.com?wpsc_action=rss'/><script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-7779456-1', 'auto');
  ga('send', 'pageview');

</script>
<script src='https://www.google.com/recaptcha/api.js'></script>
</head>
<body class="post-template-default single single-post postid-23070 single-format-standard" >
<div id="fb-root"></div>
<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.0";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>
<div class="search-cont" style="margin:0 auto; width: 991px;background-color:#ffffff;font-size:18px;"><div style="visibility: hidden; display:inline;">Towing Equipment Search:</div>  </div>
<div id="page" class="clearfloat">
<div id="header" class="clearfloat">
  <div id="branding" class="left">
    <div class="blogtitle" style="cursor: pointer; height:102px;" onclick="location.href='http://towtimes.com';"> 
    <a href="http://towtimes.com/">
        </a>
</div>
<table width="100%" border="0">
<tr>
        <td valign="bottom">
        <form method="get" id="searchform" action="http://towtimes.com/">
<input type="text" value="" name="s" id="s" class="search-widget-content search-corner-all" style="width:70%;" />
<input type="submit" id="searchsubmit" value="Search" class="button" />
</form>        </td>
  </tr>
    </table>
<table width="100%" border="0" cellpadding="0" cellspacing="0">
      <tr>
<td align="left" valign="top">
<div class="fb-like-box" data-href="https://www.facebook.com/towtimesmagazine" data-width="292" data-colorscheme="light" data-show-faces="false" data-header="false" data-stream="false" data-show-border="false"></div>
</td>
        <td align="left" valign="top">
        <a href="https://twitter.com/towtimesmag" target="_blank"><img src="http://www.towtimes.com/wp-content/uploads/2015/01/twitter.png" /></a><br/>
        <a href="http://instagram.com/towtimes?ref=badge" target="_blank"><img src="http://www.towtimes.com/wp-content/uploads/2015/01/instagram.png" /></a>
        </td>
        <td valign="top">
        <a href="http://feeds.feedburner.com/Towtimes?format=xml" title="Syndicate this site using RSS" target="_blank"><img src="http://towtimes.com/wp-content/themes/TowTimes/images/feed-icon-28x28.png" alt="RSS Feed" width="28" height="28" title="RSS Feed" /></a>
        </td>
  </tr>
</table>
<!-- Go to www.addthis.com/dashboard to customize your tools -->
<script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-555a0ae914b6e1c6"></script>

</body>
  </div>
  <div id="issue" class="left" style="text-align:center;">
  	<div class="sidebar_widget">			<div class="textwidget"><a href="http://towtimes.com/subscribe-to-tow-times/"><img src="http://towtimes.com/wp-content/uploads/2016/12/jancover4.jpg"></a><br />
<span style="text-align: center; font-size:11px;">
<a href="http://towtimes.com/?page_id=1723">Subscribe to the print edition</a><br/>
<a href="http://towtimes.com/index.php/digital-sub">Subscribe to the<br/> free digital edition</a></span></div>
		</div>  </div>
  <div class="right" style="vertical-align:bottom; width:470px;">
    <div class="banner"><!-- Error, Ad is not available at this time due to schedule/geolocation restrictions! --></div><div class="banner"><div class="a-single a-24"><a class="gofollow" data-track="MjQsMCwxLDYw" href="http://towtimes.com/towing-software-comparison/"><img src="http://towtimes.com/wp-content/uploads/2016/12/softwarechart_banner.jpg"</a></div></div>  </div>
</div>

<div id="nav" class="menu-topnav-container"><ul id="menu-topnav" class="sf-menu"><li id="menu-item-4494" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-4494"><a href="http://towtimes.com/">Home</a></li>
<li id="menu-item-4495" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4495"><a href="http://towtimes.com/shows-expos/">Show Schedule</a></li>
<li id="menu-item-4496" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4496"><a href="http://towtimes.com/state-assocshows/">Towing Associations</a></li>
<li id="menu-item-19413" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-19413"><a target="_blank" href="http://internationaltowingmuseum.org/survivor-fund-2/survivor-fund/">Survivor Fund</a></li>
<li id="menu-item-4497" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4497"><a href="http://towtimes.com/sourcebook/">SourceBook</a></li>
<li id="menu-item-4502" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4502"><a href="http://towtimes.com/store/">Tow Times Shop</a></li>
<li id="menu-item-4503" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4503"><a href="http://towtimes.com/classifieds/">Classifieds</a></li>
<li id="menu-item-5210" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5210"><a href="http://towtimes.com/contact-us/">Contact Us</a></li>
<li id="menu-item-4498" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4498"><a href="http://towtimes.com/brochuresweb-sites/">Marketing Tools</a></li>
<li id="menu-item-19836" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-19836"><a href="http://towtimes.com/media-room/">Media Room</a></li>
<li id="menu-item-5848" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-5848"><a href="#">Extra</a>
<ul class="sub-menu">
	<li id="menu-item-4499" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4499"><a href="http://towtimes.com/free-stuff/">Free Stuff</a></li>
	<li id="menu-item-7469" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-7469"><a href="http://towtimes.com/about/">About Us</a></li>
	<li id="menu-item-4500" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4500"><a href="http://towtimes.com/towsafe-program/">TowSafe Program</a></li>
	<li id="menu-item-5849" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-5849"><a href="#">Archive</a>
	<ul class="sub-menu">
		<li id="menu-item-5852" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5852"><a href="http://towtimes.com/category/national-news/">National News</a></li>
		<li id="menu-item-5853" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5853"><a href="http://towtimes.com/category/industry-news/">Industry News</a></li>
	</ul>
</li>
</ul>
</li>
</ul></div>
<div id="content">
   
  <div class="post" id="post-23070">
    <h2>
      Mag-Lok® Interconnectable Tool System from B/A Products    </h2>
    <small>Jan 6th, 2017 | By <a href="http://towtimes.com/author/editorial/" title="Posts by Editorial Staff" rel="author">Editorial Staff</a> | Category:    <a href="http://towtimes.com/category/features/" rel="category tag">Features</a>, <a href="http://towtimes.com/category/new-products/" rel="category tag">New Products</a>	        
    </small>
    <div class="entry">
       <p><img class="alignleft size-medium wp-image-23071" src="http://towtimes.com/wp-content/uploads/2017/01/Maglok-300x200.jpg" alt="" width="300" height="200" srcset="http://towtimes.com/wp-content/uploads/2017/01/Maglok-300x200.jpg 300w, http://towtimes.com/wp-content/uploads/2017/01/Maglok-768x512.jpg 768w, http://towtimes.com/wp-content/uploads/2017/01/Maglok-180x120.jpg 180w, http://towtimes.com/wp-content/uploads/2017/01/Maglok-96x64.jpg 96w, http://towtimes.com/wp-content/uploads/2017/01/Maglok-38x25.jpg 38w, http://towtimes.com/wp-content/uploads/2017/01/Maglok-323x215.jpg 323w, http://towtimes.com/wp-content/uploads/2017/01/Maglok-220x147.jpg 220w, http://towtimes.com/wp-content/uploads/2017/01/Maglok-150x100.jpg 150w, http://towtimes.com/wp-content/uploads/2017/01/Maglok.jpg 800w" sizes="(max-width: 300px) 100vw, 300px" />B/A Products Co. now offers the Mag-Lok® Interconnectable Tool System that saves  valuable space, weight and streamlines the storage of your equipment. The system pairs industrial grade handles with interchangeable tool heads capable of standing up to the rigors of commercial use</p>
<p>Choose only the handle(s) that you need coupled with the job specific tool heads that you require.</p>
<p>Mag-Lok® provides a lifetime guarantee on all of its handles and tool heads.  Made in the U.S.A.</p>
<p>For more information visit <a onclick="javascript:pageTracker._trackPageview('/outgoing/www.baprod.com');"  href="http://www.baprod.com" target="_blank">www.baprod.com</a>.</p>

          </div>
                
  </div>
    </div>
<!--BEGIN SIDEBAR-->
<div id="sidebar">
	   
    <br />
  <div id="sidebar-left">
    </div>
  <div id="sidebar-right">
    </div>
  <div style="clear:both;"></div>
  <div class="sidebar_widget"><div class="a-single a-6"><a class="gofollow" data-track="NiwwLDEsNjA=" href="http://www.safetyvision.com/trucks-highway#anchor-36"><img src="http://towtimes.com/wp-content/uploads/2016/02/towTimes_0216.jpg"  alt="Safety Vision" style="width:300px;height:250px; margin-bottom:15px;"></a></div></div><div class="sidebar_widget"><div class="a-single a-7"><a class="gofollow" data-track="NywwLDEsNjA=" href="http://www.specialtyvehiclefunding.com" target="_blank"><object width="300" height="250" classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=6,0,40,0"><param name="src" value="http://towtimes.com/wp-content/uploads/2012/08/336X280_01.3.swf" /><embed width="300" height="250" type="application/x-shockwave-flash" src="http://towtimes.com/wp-content/uploads/2012/08/336X280_01.3.swf" /></object></a></div></div><div class="sidebar_widget"><div class="a-single a-18"><div id="googlead" style="margin-top:20px;text-align:center;">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- 250 x 250 -->
<ins class="adsbygoogle"
     style="display:inline-block;width:250px;height:250px"
     data-ad-client="ca-pub-6784611133773551"
     data-ad-slot="0236332882"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div></div></div>    <br /><br />
</div>
<!--END SIDEBAR--></div>
<div id="footerads"> 
	    
  </div>
<div id="footer">
	<a href="http://www.towtimes.com/?page_id=2">About Us</a> | 
	<a href="http://www.towtimes.com/?page_id=186">Advertising Info</a> | 
  <a href="http://www.towtimes.com/?page_id=6">Contact Us</a> | 
<a href="http://www.towtimes.com/?page_id=4875">Sitemap</a> | 
<a href="http://www.towtimes.com/index.php/privacy-policy/">Privacy Policy</a> | 
<a href="http://www.towtimes.com/index.php/terms-of-use/">Terms of Use</a>
  <br /><br />
  <!-- ngg_resource_manager_marker --><script type='text/javascript'>
/* <![CDATA[ */
var click_object = {"ajax_url":"http:\/\/towtimes.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='http://towtimes.com/wp-content/plugins/adrotate/library/jquery.adrotate.clicktracker.js'></script>
<script type='text/javascript' src='http://towtimes.com/wp-content/plugins/wp-jquery-lightbox/jquery.touchwipe.min.js?ver=1.4.6'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var JQLBSettings = {"showTitle":"1","showCaption":"1","showNumbers":"1","fitToScreen":"0","resizeSpeed":"400","showDownload":"0","navbarOnTop":"0","marginSize":"0","slideshowSpeed":"4000","prevLinkTitle":"previous image","nextLinkTitle":"next image","closeTitle":"close image gallery","image":"Image ","of":" of ","download":"Download","pause":"(pause slideshow)","play":"(play slideshow)"};
var JQLBSettings = {"showTitle":"1","showCaption":"1","showNumbers":"1","fitToScreen":"0","resizeSpeed":"400","showDownload":"0","navbarOnTop":"0","marginSize":"0","slideshowSpeed":"4000","prevLinkTitle":"previous image","nextLinkTitle":"next image","closeTitle":"close image gallery","image":"Image ","of":" of ","download":"Download","pause":"(pause slideshow)","play":"(play slideshow)"};
/* ]]> */
</script>
<script type='text/javascript' src='http://towtimes.com/wp-content/plugins/wp-jquery-lightbox/jquery.lightbox.min.js?ver=1.4.6'></script>
<script type='text/javascript' src='http://towtimes.com/wp-includes/js/wp-embed.min.js?ver=516e2db58fd921c13ab8ee4ab4d665b0'></script>

<!-- tracker added by Ultimate Google Analytics plugin v1.6.0: http://www.oratransplant.nl/uga -->
<script type="text/javascript">
var gaJsHost = (("https:" == document.location.protocol) ? "https://ssl." : "http://www.");
document.write(unescape("%3Cscript src='" + gaJsHost + "google-analytics.com/ga.js' type='text/javascript'%3E%3C/script%3E"));
</script>
<script type="text/javascript">
var pageTracker = _gat._getTracker("UA-7779456-1");
pageTracker._initData();
pageTracker._trackPageview();
</script>
  <div>
    Tow Times&reg; Online is published by TT Publications Inc. No part of this Web site may be reproduced without written permission of TT Publications Inc. unless otherwise stated.<br />
    Tow Times&reg; Online endeavors to provide accurate and authoritative information regarding vehicle towing and recovery. However, neither the publisher, editor,<br />any staff nor stockholder is engaged in providing professional opinions of any nature. If technical or professional advice is required in any aspect of your business,<br />we encourage our viewers to seek professional services.<br />
    &#169; 2017  TT Publications, Inc.
    <div></div> 
    <a rel="nofollow" href="http://towtimes.com/towtimes-login">Log in</a> | 
      </div>
</div>
</body>
</html>